Visual Editor Not Working Properly

Support Area Forums Foundation Visual Editor Not Working Properly

Tagged: 

This topic contains 3 replies, has 2 voices, and was last updated by  Bill Robbins 1 year, 1 month ago.

Viewing 4 posts - 1 through 4 (of 4 total)
URL to the page in question: http://
  • Author
    Posts
  • #37842

    Deborah Gabriel
    Participant

    The visual editor is not displaying properly and I cannot access the screen options menu as it won’t drop down. This seems to be a theme problem as I switched to twenty sixteen and the visual editor works just fine.

    I have tried disabling plugins to see if that is where the problem lies but it makes no difference.

    This could be related to a previous post: “Home widgets not aligned properly after WordPress 4.6 update”. Your fix worked on my other site on this domain but not this one: http://blacksisternetwork.blackbritishacademics.co.uk/

    Advice welcome.

    Attachments:
    #37844

    Bill Robbins
    Moderator

    Hi Deborah,

    It looks like quite a few WordPress scripts are not loading. I’ve attached a screenshot of what the error console looks like on the front page. The lines that make reference to wp-includes are ones that are loading items included in the WordPress core itself. I can’t see the backend of your page editor to check the source code there, but it’s highly likely that this issue is what is affecting it as well. The editor is powered by javascript so if there are items missing, the errors can keep it from loading.

    Here’s what I would suggest. Go to the updates section of your Dashboard. At the top of that screen you can either update WordPress if there is a pending update, or you can reinstall the current version. Update if you can, otherwise reinstall the existing version. Occasionally when something is wrong with these type of files, reinstalling will fix it.

    Hope that helps out,
    Bill

    Attachments:
    #37846

    Deborah Gabriel
    Participant

    Hi Bill,

    I think you could be right. I have tried reinstalling via the dashboard and it did reinstall successfully but the problem still persists. I think I may have to uninstall WordpPress and reinstall using export files to preserve the content. I can’t think what else to do.

    #37847

    Bill Robbins
    Moderator

    If you have access to a FTP program, here’s what to do. Download the current version of WordPress from wordpress.org and unzip the archive. Open up the folder and delete the wp-content folder from the download. Then move all the files and folders to the root of your WordPress installation on your server. That will replace all the existing core files with the new ones, but it won’t replace the wp-content folder that has all your uploads, plugins and themes.

    The export contains written content, but it doesn’t contain any files like the images you’ve uploaded to your site. So it’s not a complete backup of your content. The files have to be present on the server in order for that to work.

    If uploading the core files doesn’t fix it, then it could be a server issue. Your web host might be able to help out better if that’s the case.

    Hope that helps out,
    Bill

Viewing 4 posts - 1 through 4 (of 4 total)

The topic ‘Visual Editor Not Working Properly’ is closed to new replies.