Podcast Broken

Support Area Forums Pneuma Podcast Broken

This topic contains 5 replies, has 2 voices, and was last updated by  Bill Robbins 1 year ago.

Viewing 6 posts - 1 through 6 (of 6 total)
URL to the page in question: http://harbourfellowship.com/
  • Author
    Posts
  • #37269

    Samuel
    Participant

    Not sure if this is a theme problem or something else but it appears that our podcast/itunes link is not working.

    Any advice would be appreciated.

    #37272

    Bill Robbins
    Keymaster

    Hi Samuel,

    Sorry for the trouble there. I did a bit of digging around and I think I’ve spotted some code that needs to be changed in the podcast feed. Let’s do this. Go to the Appearance section in your WordPress dashboard and click on Edit. From the list of files on your right, choose podcast-feed-page.php. Replace all the code on the page there with this:


    (See support site for full code)

    and save your changes. That should do two things. It should help out the individual podcast artwork files and it will give a default duration to the length of the podcast episode. iTunes requires a duration and will remove feeds that don’t have durations present. This will give a fallback in case it’s empty.

    Try updating the feed with iTunes after making those changes and see if that doesn’t help out. Let me know if you run into any trouble there.

    Bill

    #37294

    Samuel
    Participant

    Thanks very much

    Only 1 error left! I get this message: “Can’t submit your feed. There is no explicit tag in your feed, or the explicit tag is empty.”

    I see no place on podcast-feed to list our podcast as non explicit. are you able to fix this in the theme or in the feed’s code.

    #37304

    Bill Robbins
    Keymaster

    Hey Samuel,

    Sorry about that. The explicit tag has been optional for years with iTunes but it looks like they are requiring it now. I’ve updated the code above. You can follow the steps from the earlier post to replace the code in the page with new code (line 50 adds the explicit tag). See if that doesn’t do the trick.

    Let me know how it goes,
    Bill

    #37305

    Samuel
    Participant

    That appears to have worked

    Bill, you are amazing

    Blessings

    #37306

    Bill Robbins
    Keymaster

    Glad that appears to have done the trick. Sorry again for the trouble there. I’ll roll the changes into a theme update so everyone can have them too.

    Have a great weekend,
    Bill

Viewing 6 posts - 1 through 6 (of 6 total)

The topic ‘Podcast Broken’ is closed to new replies.