Hero Page Gallery Link

Support Area Forums Selfie Hero Page Gallery Link

Viewing 6 posts - 1 through 6 (of 6 total)
URL to the page in question: http://www.different-perspective.co.uk
  • Author
    Posts
  • #22753
    David Pearce
    Participant

    Bill

    What a great site you have created here. Very impressive and great support forum. I have been able to follow the instructions easily even with Twitter and then using custom CSS. This is good for me!!!

    I wanted to link my hero page to the gallery and followed the advice on this help topic :-

    https://support.organizedthemes.com/forums/topic/link-title-to-the-gallery/

    I would now like to know how to remove the little + signs in the circles please? Can this be done?

    Many thanks

    #22755
    Bill Robbins
    Moderator

    Good Morning David,

    Thank you for your business. It’s also good to hear that you’ve found the posts helpful too.

    Excellent question. The plus sign in the circle is added with a bit of CSS which lets us customize or remove it without much trouble. Here’s how to take it out:

    1. Go to your theme options page and choose the Advanced tab.
    2. Scroll down to the Custom CSS box and add this:
      
      a.pop-open:before {
      	content: '';
      }
      
    3. Update your settings.

    See if that doesn’t do the trick for you.

    Great looking site by the way. If you need anything else, just let me know.

    Thanks,
    Bill

    #22756
    David Pearce
    Participant

    WOW – that was a super speedy reply. Thank you 🙂

    This has worked perfectly. My next issue is that the gallery will not open when you click the link – just the image. I have changed the id and added the code (removed the first >tag here so it shows):-

    <h2>a rel=”swipe-group-111″ href=”http://www.different-perspective.co.uk/wp-content/uploads/2014/09/Cover.jpg&#8221; class=”swipebox pop-open”>Open Gallery</h2>

    Can you see what I have done wrong? I have attached an screen grab of the nag bar in the edit Home Block page

    #22759
    Bill Robbins
    Moderator

    Hey David,

    I took a quick look. On my end it looks like when I click on Open Gallery, the hero image comes up twice before the rest of the gallery images. Is that what you’re seeing too?

    Since you’re adding in a link to open up the lightbox in each block, let’s remove the built-in one completely. That should take care of the duplicated first image. Here’s how to do that:

    1. Go to the Appearance section in your WordPress dashboard and choose Edit.
    2. From the list of files on your right, choose page-home-template.php
    3. Find this line:
      
      <a rel="swipe-group-<?php the_ID(); ?>" title="<?php the_title(); ?>" href="<?php echo wp_get_attachment_url( get_post_meta($post->ID, "portfolio_hero", true) ); ?>" class="swipebox pop-open"></a>
      

      and delete it.

    4. Save your changes.

    That should take out the default link that opens up the lightbox. With that link gone, you’ll have to add a manual one each time you’d like to open the ligthbox, but it should do that without showing the hero image twice.

    Let me know if you have trouble there.

    Thanks,
    Bill

    #22761
    David Pearce
    Participant

    Thanks Bill – that fixed it 🙂

    Is there anyway to keep the nav arrows displayed on a permanent basis in the swipe gallery?

    #22763
    Bill Robbins
    Moderator

    I’m glad that did the trick for you 🙂

    In the theme options page on the advanced tab, there is a field where you can set the number of seconds before the bars hide themselves. It’s in milliseconds so you can pick a really large number like 50000 which would cause the bars not to hide for 50 seconds. The lightbox (swipebox.js) won’t hide them on mobile, but there isn’t an option to keep them always present on desktops.

    Take care,
    Bill

Viewing 6 posts - 1 through 6 (of 6 total)
  • The topic ‘Hero Page Gallery Link’ is closed to new replies.