Twitter widget won't work even after css added

Support Area Forums Photobug Twitter widget won't work even after css added

This topic contains 7 replies, has 2 voices, and was last updated by  Bill Robbins 4 years, 2 months ago.

Viewing 8 posts - 1 through 8 (of 8 total)
URL to the page in question:
  • Author
    Posts
  • #13719

    steve berchtold
    Participant

    Hey Bill,

    I added the Twitter widget, but even after adding css, it shows up messed up. See the screenshot.

    Thanks,
    Steve

    #13723

    Bill Robbins
    Moderator

    Good morning Steve,

    Any chance you could leave the widget in your header so I can take a look at the code there?

    Thanks,
    Bill

    #13730

    steve berchtold
    Participant

    Hey Bill, Yes, there’s a real good chance I could. I’ll put it back up for you right now. Just didn’t want to leave it that way till I heard back form you…

    #13731

    Bill Robbins
    Moderator

    Thanks Steve,

    Let’s change some of the options in the Twitter widget. That space is designed to just display your latest tweet only. To have it look right, here’s how you’ll want to change the options:

    Don’t display your twitter image.
    Set it to display only one tweet.
    Hide the sending application.
    Do not display the Twitter Intents.
    Do not display a follow link.

    If you’ll change it to those, that should get it.

    Let me know if you run into any trouble,
    Bil

    #13735

    steve berchtold
    Participant

    Awesome Bill. Thanks. Now, how do I get the background of the twitter block to have a white background?

    #13736

    Bill Robbins
    Moderator

    That’s made with an image, so the only way to change its color is by editing the image itself. I made one with a white background here. You can right click it and save it to your computer:

    After you’ve done that, go to the Media section in your WordPress control panel and select Add New. Upload the image and click the edit link once the upload is finished.

    Look on the right hand side of the edit screen. You’ll see a box labeled File URL. Copy that URL from the box.

    Next go to the Styling tab in the Theme Options page. Scroll down to the Custom CSS box and paste this:

    
    .header-sidebar .widget_twitter,
    .header-sidebar .latest-tweets {
    	background: url(http://yoursite.com/image.png) no-repeat left top;
    }
    

    Then replace the http://yoursite.com/image.png with the URL you copied earlier. Update your settings and that should change out the silver background for a white one.

    If you have any trouble, let me know,
    Bill

    #13737

    steve berchtold
    Participant

    Thanks Bill. Lots of styling additions I like to do. I’m into better looking sites.

    Appreciate it!

    Steve

    #13738

    Bill Robbins
    Moderator

    Anytime Steve. Have a great week!

Viewing 8 posts - 1 through 8 (of 8 total)

The topic ‘Twitter widget won't work even after css added’ is closed to new replies.