Menu not working on mobile.

Support Area Forums Foxy Menu not working on mobile.

This topic contains 2 replies, has 2 voices, and was last updated by  Bill Robbins 1 year, 9 months ago.

Viewing 3 posts - 1 through 3 (of 3 total)
URL to the page in question: http://thelakeviewhouse.com
  • Author
    Posts
  • #33142

    Stuart Berg
    Participant

    Bill;

    Thank you again for all your help and I am sorry to bother you again with something that really isn’t your products fault.

    As I told you before I solved my clients menu preference with the free version of a plug in called Max Mega Menu.

    After the initial layering issue it works great on PC and tablets. But not on mobile.

    I would actually be fine with your regular menu on mobile but I actually don’t have any mobile navigation.

    I have tried their forum for support but haven’t gotten any response. https://wordpress.org/support/topic/no-menu-on-mobile-4?replies=2#post-7503985

    I found an article that points to Removing Residual Styling to solve the issue http://www.maxmegamenu.com/documentation/faqs/removing-residual-styling/
    on their forums but I’m not sure if that is my issue as I admit I’m not good with CSS at all.

    I have attached my header.php file. If you could take a quick look and give me any advise it would be greatly appreciated.

    Thanks
    Stuart

    Attachments:
    1. lvh-header_php.txt
    #33144

    Bill Robbins
    Keymaster

    Hi Stuart,

    Let’s do this. There is a separate menu location in the theme for the mobile menu. Go on and assign a menu to that spot. When can then hide the mega menu on smaller screens but make the original mobile menu show up there. We can make that happen via CSS.

    Once you have a menu assigned to the mobile menu location, let me know and we’ll go from there.

    Bill

    #33151

    Bill Robbins
    Keymaster

    Thanks Stuart for adding that. Let’s do this:

    1. Go to your theme options page and choose the Style tab.
    2. Scroll down to the Custom CSS box and add this:
      
      #mobile-menu {
      	display: none;
      }
      
      @media only screen and (max-width: 767px) {
      
      	#mobile-menu {
      		display: block;
      	}
      	
      }
      
    3. Update your settings.

    See if that doesn’t do the trick for you. I believe the navigation button takes the same styling as the default navigation menu items so you can use that styling to change how it looks if you’d like to.

    Let me know how that goes,
    Bill

Viewing 3 posts - 1 through 3 (of 3 total)

The topic ‘Menu not working on mobile.’ is closed to new replies.