Gallery Format on a Full Page Template

Support Area Forums Bottega Gallery Format on a Full Page Template

This topic contains 10 replies, has 2 voices, and was last updated by  Bill Robbins 1 year, 7 months ago.

Viewing 11 posts - 1 through 11 (of 11 total)
URL to the page in question: http://www.gadsbys.ca/trends/
  • Author
    Posts
  • #36290

    G Gadsby
    Participant

    When I try and insert a new gallery on this page, I get the gallery in the content area of the page, but I also get a scrolling banner above the content area of the page. The banner contains random images and the ones in my page gallery. I would prefer actually to have the images appear in the banner area only and only the images that I have specified for the gallery. I can’t figure how to get one and not the other or how to remove the unwanted images from the scrolling banner.

    #36291

    Bill Robbins
    Moderator

    Great question. In Bottega, the format sets how the image in the header works. If you go with “gallery” it will take all the images that were uploaded while editing that post and make a slideshow of them. The image format will display the featured image there and video will use the embed code that you’ll see in the right hand side while editing a page to display a video.

    Since you’re looking to just have a photo gallery in the content of the page I would use a different format than gallery. If you want to have just an image there, then use the image one and set a featured image. If you’d rather not have anything there, then just go with the standard format.

    Let me know if you run into any trouble there,
    Bill

    #36292

    G Gadsby
    Participant

    Thanks Bill,
    If I understand you correctly, when I am editing a page I could mess up a “gallery” if I upload images that I decide afterward I don’t want to show up on that page. They will show up anyway.

    I would like to have a slideshow of three images at the top of the page, would it be best to scrap the original page and create a new one from scratch?

    #36293

    Bill Robbins
    Moderator

    What you can do is “detach” the images you no longer want in the slideshow from the page. To do that, go to the media library in your WordPress dashboard. In the top left you’ll see an icon to switch from the default grid view to a list view.

    Click on that and one of the columns you’ll now see is for “Uploaded to.” Find the image you want and then use the detach link in the uploaded to column to remove the connection between the image and the page. It’ll leave the image in the library, but should take it out of the slideshow. You should also be able to add images from the library to a page’s slideshow by using the attach button there.

    See if that doesn’t work for you without having to delete the page.

    #36294

    G Gadsby
    Participant

    I was able to remove the unwanted images. That worked great through the media library. How do I get the page to only show the slideshow at the top and not the slideshow in the black box below it?

    #36295

    Bill Robbins
    Moderator

    I think the slideshow with the black background is coming from the Jetpack plugin. You should be able to turn off the module that’s creating it inside Jetpack’s settings.

    #36300

    G Gadsby
    Participant

    Thanks Bill, I opened up the source code and see the reference to “jetpack-slideshow.” Unfortunately I can’t find any setting remotely related in the Jetpack settings. The closest is “Carousel” and turning it off and re-saving the page didn’t have any effect on the page’s appearance. I’ll see if I can track something down through Jetpack support. The only way I could get rid of it was to deactivate the entire “jetpack” plugin.

    • This reply was modified 1 year, 7 months ago by  G Gadsby.
    #36301

    G Gadsby
    Participant

    On the other part of the initial question, when I create a new page, how do I get the gallery images to show up as the nice banner across the top, like the home page banner? They are appearing in this way on the Trends page, but I don’t know why or how. When I create a new page, gallery images only appear with the ugly black ‘jetpack’ slideshow box that requires Java.

    • This reply was modified 1 year, 7 months ago by  G Gadsby.
    #36305

    Bill Robbins
    Moderator

    One way to create a page with a slideshow at the top is this. Add a new page, or edit an existing one. Look for the format box on your right while you’re editing and choose the gallery format. The gallery format is what triggers the header slideshow to appear.

    Now click on the Add Media button just above the main content box and add your images there. You don’t need to insert the images into the content of the page, but by uploading them while editing they will be “attached” to the page and appear in the slideshow.

    You can also attach/detach images inside the media library as well when using the list view instead of the grid one.

    I believe the slideshow may be part of the tiled galleries module in Jetpack. If there is a gallery inserted into the content of the page, you could delete it and that should take out the slideshow. If it is being added automatically try turning off that module. If worse comes to worst, we can hide it via CSS, but that I wouldn’t want that to be the first option. If you do need to do that, add this to the Custom CSS box that’s at the bottom of the Advanced tab in the theme options page:

    
    .slideshow-window {
    	display: none;
    }
    

    Let me know how that goes,
    Bill

    #36308

    G Gadsby
    Participant

    That’s helped. I removed the gallery entirely from the page and now I just have the slideshow across the top. Thanks again!

    #36309

    Bill Robbins
    Moderator

    Sweet! If you have any other questions, let me know.

Viewing 11 posts - 1 through 11 (of 11 total)

The topic ‘Gallery Format on a Full Page Template’ is closed to new replies.