Featured Images Missing on Blog Page

Support Area Forums Pneuma Featured Images Missing on Blog Page

This topic contains 5 replies, has 2 voices, and was last updated by  Bill Robbins 1 year, 8 months ago.

Viewing 6 posts - 1 through 6 (of 6 total)
URL to the page in question: http://myquarterturns.com/arya/blog/
  • Author
    Posts
  • #34665

    Carly Gardner
    Participant

    Hi Bill,

    I’ve imported a bunch of blog posts from a client’s old site and need to re-add all the featured images manually.

    I’ve added the first one to this post (http://myquarterturns.com/arya/2015/12/18/holiday-lessons-from-clark-griswold/) but it doesn’t seem to show up on our Blog page like it does in your demo. Only the top 2 blog posts have a featured image, I want to wait to fix this before I do the rest.

    http://myquarterturns.com/arya/blog/

    Any thoughts?

    The only custom CSS I’m using makes the .wrap full width.

    Thanks,

    Greg

    #34668

    Bill Robbins
    Moderator

    Hi Greg,

    I took a look and I think this snippet in the Custom CSS is hiding the featured image, along with the post title and author line:

    
    header.entry-header {
         display: none;
    }
    

    The featured image loads inside of the entry-header so I believe once it’s displaying again, you’ll be able to see it.

    Let me know if you run into trouble.

    Have a Happy New Year,
    Bill

    #34678

    Carly Gardner
    Participant

    I removed that code but the result is the same. The page title returns but no featured images. Sorry I should have mentioned that I had already tried that.

    #34681

    Bill Robbins
    Moderator

    I made it back home where I could take a better look. It appears that the page is also picking up the hidden title option. The way that works, it hides the title, featured image and the post meta information. If you do have that selected, uncheck that to make sure those show up.

    Also on the “single view” of each individual post, the featured image is not set to display there. In Pneuma the only spot it is visible is in the archive view, like the full blog page.

    If you can’t disable the hidden title, let me know.

    #34724

    Carly Gardner
    Participant

    Ah I see, the ‘hide title’ box was checked on the individual posts themselves. I was just looking at the ‘blog’ page. That fixed it. Thanks!

    • This reply was modified 1 year, 8 months ago by  Carly Gardner.
    Attachments:
    #34727

    Bill Robbins
    Moderator

    Hi Greg,

    That’s my bad for mentioning to check on the individual posts, particularly the first one for the hidden title. WordPress ignores everything on the “posts page” except for the page title and the URL slug. Everything else it just skips over. I’ll see if I can hide that box on the post page in future updates since it doesn’t do anything there.

    Have a wonderful New Year and let me know if you need anything,
    Bill

Viewing 6 posts - 1 through 6 (of 6 total)

The topic ‘Featured Images Missing on Blog Page’ is closed to new replies.