500 internal server error only in admin–>widget

Support Area Forums Moonrise 500 internal server error only in admin–>widget

This topic contains 5 replies, has 2 voices, and was last updated by  Bill Robbins 1 year, 5 months ago.

Viewing 6 posts - 1 through 6 (of 6 total)
URL to the page in question: http://www.trattoriastazione.com
  • Author
    Posts
  • #35380

    Pietro Mori
    Participant

    hi Bill
    the website and the admin panel work normally but in admin panel when i try to access on the widget page i get a server error (500 internal server error)
    I try disable all plugin but still don’t work.
    wp has been installed in a subdirectory for testing and everything worked.
    Now i’ve copied index and htaccess in the root and all work fine except widget page
    any suggestion?

    Thanks,
    Pietro

    #35389

    Bill Robbins
    Keymaster

    Good Morning Pietro,

    Thank you for your business first of all. Sorry for the trouble there. Does the widget section in the customizer work or does it give you an error as well?

    Thanks,
    Bill

    #35401

    Pietro Mori
    Participant

    ops, I did not had tried but in the customizer work …. very strange

    if it could be useful i turned on debug and in the log (500kb in a day) there are only these two notice

    [08-Feb-2016 19:54:46 UTC] PHP Notice: Array to string conversion in /web/htdocs/www.trattoriastazione.com/home/wp/wp-content/themes/moonrise/includes/fonts.php on line 191
    [08-Feb-2016 19:55:24 UTC] PHP Notice: Il metodo di costruzione richiamato per WP_Widget รจ deprecato dalla versione 4.3.0! Utilizzare invece

    __construct()

    . in /web/htdocs/www.trattoriastazione.com/home/wp/wp-includes/functions.php on line 3624

    #35404

    Bill Robbins
    Keymaster

    The widget constructors are still the old version which is deprecated with WP 4.3. They should still function though as long as your host isn’t running PHP 7; which is something you would need to have requested.

    When the theme is updated next, those constructors will be updated to the new style. I’m glad you’re able to access widgets via the customizer. Eventually that will be the only spot where you an access widgets and navigation menus.

    Thanks,
    Bill

    #35405

    Pietro Mori
    Participant

    But I think that the problem is not that. Before to move in the root no issue
    Maybe some wrong path?
    anyway no problems Bill
    the costumizer works.
    Thank you for the help

    Ciao
    Pietro

    #35406

    Bill Robbins
    Keymaster

    Since that’s the only page that’s off, we might check the URL for that page. Would you mind copying the URL for your widgets screen out and pasting it here. That might shed some clues on it.

    It could also be a permissions issue on the server. Or something may have gone slightly wrong moving the .htaccess file. Since it did work, I would tend more towards a permissions or wrong path issue.

Viewing 6 posts - 1 through 6 (of 6 total)

The topic ‘500 internal server error only in admin–>widget’ is closed to new replies.